Настройка обновления страницы после выбора атрибутов фильтра

Статус
В этой теме нельзя размещать новые ответы.

apWeb

Пользователь
#1
Добрый день, подскажите пожалуйста куда копать где и что искать, проблема заключается в том что, установил фильтр товаров, фильтр отображается и работает но...
после выбора производителя, там где к примеру всего 3 товара: появляется очень много одинаковых страниц они все пустые и отображаются одинаковые товары.


после того как обновляю страницу появляется только 3 товара как и должно быть:


как можно исправить данную проблему? Я так понимаю то что при выборе определенного производителя, магазин не обновляет страницу с правильным выбором. Т.е адресная строка меняется, но не отображает правильно товары, после обновление страницы вручную все отображается как нужно.
 

Faraon

Админ
Команда форума
#5
@apWeb, а что мешает поставить другой фильтр? видимо нужно адаптировать под шаблон
 

apWeb

Пользователь
#6
@apWeb, а что мешает поставить другой фильтр? видимо нужно адаптировать под шаблон
Ставил разные фильтры все равно тоже так пока не обновлю корректно отображаться не будет даже на дефолтном шаблоне, на OpenServer'e стоит этот же шаблон, но тут все работает.
 

Faraon

Админ
Команда форума
#7
@apWeb, значит на опенсервере включено может что то, что не включено на хостинге. сравнивай настройки php. дело значит в самом хостинге, попробуй залить магаз на какой то бесплатный например на бегет, и посмотри если все норм то долби в техподдержку хоста
 

apWeb

Пользователь
#8
@apWeb, значит на опенсервере включено может что то, что не включено на хостинге. сравнивай настройки php. дело значит в самом хостинге, попробуй залить магаз на какой то бесплатный например на бегет, и посмотри если все норм то долби в техподдержку хоста
Спасибо, так и думал сделать, буду так делать.
 

Faraon

Админ
Команда форума
#9
а можно проще, возьми настройки php с опенсервера, и отправь тех поддержке. пусть выставят тебе такие же
 

apWeb

Пользователь
#10
а можно проще, возьми настройки php с опенсервера, и отправь тех поддержке. пусть выставят тебе такие же
Все сделал, оказывается небыло включено : mcrypt и не правильно был настроен CSS селектор DOM-элемента который включает в себя только блоки с товарами, переписал и все стало гуд. Спасибо, тему можно закрывать
 
Статус
В этой теме нельзя размещать новые ответы.
Сверху