Какую версию движка выбрать? Opencart 2.3.х или 3.х?

#1
Пока интернет-магазин на стадии открытия ручки тянутся поставить 3.х.
Кто что думает по этому поводу?
Очевидные вещи типо модуль не поддерживает или шаблон не поддерживает 3.х можно не писать )))
 
#2
Смотря какие требования, лучше конечно 3 ставить, если все нужные модули есть и много кастома не требуется.
Я на 2.3 сижу, так как слишком много кастома на нее накидал уже, но если бы сейчас начинал, собирал бы на 3.x + php7.2
 
#4
Смотря какие требования, лучше конечно 3 ставить, если все нужные модули есть и много кастома не требуется.
Я на 2.3 сижу, так как слишком много кастома на нее накидал уже, но если бы сейчас начинал, собирал бы на 3.x + php7.2
Заманчиво, но хотелось бы какой-то конкретики от тех кто работал с 3.x ... Я его поставил ну вроде никаких особо новых функций не видно ... А php 7.2 мне кажется и 2.3 потянет. На php 7.2, конечно нужно обновиться ... жду пока vestaCP выйдет нормальная и Ubuntu 19.04 параллельно начнет побольше поддерживать модулей для php 7.2 ... Хотя php 7.2 кажется можно и на Ubuntu 16.04 поставить ... сейчас просто не до этого немного.
 
#5
@asky, php 7.2 рано.... под php 7.1 не все есть еще.
Опачки, ценное замечание ... а то я после того как проверил сайт через OWASP ZAP загорелся на php 7.2 перейти. Тогда все отменяется ...
Раз доводов в пользу 3.х нет, и звезды говорят остаться на 2.3 так тому и быть.
 

Faraon

Админ
Команда форума
#6
@AlektroNik, изучите модули которые вам нужны для работы, посмотрите под какие версии они есть и под какие php и на основе этого решайте
 
#7
@AlektroNik, изучите модули которые вам нужны для работы, посмотрите под какие версии они есть и под какие php и на основе этого решайте
Да это я уже все изучил. Просто хотел услышать, что же хорошего в 3.х Ну как минимум на будущее ... но нигде не могу найти эту информацию ... какую-нибудь сравнительную табличку что ли 2.3 и 3.х.
 
#10
@asky, php 7.2 рано.... под php 7.1 не все есть еще.
Вот я и написал, зависит от требований, уже можно сделать хорошую сборочку по функционалу на 3 + php7.2, а мелкие модули можно подправить. Но в общем то да, смысла ставить в большинстве случаев нету 3, как и php7, если цель просто магазин открыть, а не заниматься разработкой.
 
#11
@AlektroNik, я бы не спешил переходить на 3-ю версию еще как минимум месяцев 6-ть. Под 2.3 значительно больше модулей, значительно больше пользователей, которые построили свои проекты на 2.3, отсюда и поддержка в случае оказания помощи значительно больше. Я год назад переходил с 2.1 на 2.3 именно по причине устаревания модулей и огромной армии пользователей 2.3. Посмотрел 3.х на тестовом сервере, как и написавшие выше, смысла переходить на 3-ю версию пока нет, ничего революционно нового в ней пока, увы нет.
 
Последнее редактирование:

xjfg

Пользователь
#13
Ещё немного и можно уже на 3.0.3 переходить, основные модули и шаблоны уже поддерживаются
Так же на подходе сборка Brocart, уже на 3.0.3 с админкой от 2.3 и обещают много интересных плюшек в сборке
В сборке будет реализация сео и расширенный редактор заказов и самое интересное чего ожидаю лично я, это реализация в сборке ява разметки
Уже сгораю от нетерпения поюзать сборку)))
 

mcreper

Пользователь
#17
Также некоторое время думал о переходе на 3 версию, но все же решил подождать следующих версий, так как существенного преимущества для своих магазинов не увидел.
 
Сверху